Set HUDI Icon Problem

Posted in Mod Help
Unsubscribe from this topic
Hi, i was doing a pre-mission, in that, homer and berney have a conversation, the intention is that a conversation appears with the image of the character that is speaking and the message, this is developed in mXsdi and I load it in mXsdl, however the problem appears at the moment in which the image of the character that speaks only appears the text message and not the image, I check it several times and I do not find error, I attached the script here and put comments for better understanding, any help will be very grateful
SelectMission("m0sd");

SetMissionResetPlayerOutCar("level1_homer_start", "level1_carstart");
SetDynaLoadData("l1z1.p3d;l1r1.p3d;l1r7.p3d;");

UsePedGroup( 0 );

SetMissionStartCameraName( "mission0camShape" );
SetMissionStartMulticontName( "mission0cam" );
SetMissionStartCameraName( "mission0camShape" );
SetMissionStartMulticontName( "mission0cam" );

//UP ISNT IMPORTANT

SetInitialWalk("level1_homer_walkto");

//Firts stage homer walk to barney and under apper "talk to barney"
AddStage();
	RESET_TO_HERE();
	SetMaxTraffic(3);
	SetHUDIcon("barne");	
	SetStageMessageIndex(00);
	AddObjective("talkto","neither");
		AddNPC("barney", "m1_marge_sd");
		SetTalkToTarget("barney", 0, 0.2);
	CloseObjective();
CloseStage();

//Attention
AddStage();
	SetHUDIcon("barne");  //barney image, which does not appear
	AddObjective("timer");  //the time
		AddNPC("barney", "m1_marge_sd");  //barney
		SetStageMessageIndex(05); //the text message
		SetDurationTime(3.2);  //time
	CloseObjective();
CloseStage();

AddStage();
	SetHUDIcon("homer");         //again but with homer
	AddObjective("timer");
		AddNPC("barney", "m1_marge_sd");   //barney
		SetStageMessageIndex(06);  //text message
		SetDurationTime(3.2);  //time
	CloseObjective();
CloseStage();

AddStage();
	SetHUDIcon("barne");//barney image, which does not appear
	AddObjective("timer");
		AddNPC("barney", "m1_marge_sd"); //barney
		SetPresentationBitmap( "art/frontend/dynaload/images/mis01_00.p3d" ); //the mission
		SetStageMessageIndex(07);//the message
		SetDurationTime(3.2); //time
	CloseObjective();
CloseStage();

CloseMission();

And the mXsdl is in order, you can see it here
LoadP3DFile("art\missions\level01\mission0cam.p3d");

LoadP3DFile( "art\frontend\dynaload\images\msnicons\char\barne.p3d );
LoadP3DFile( "art\frontend\dynaload\images\msnicons\char\homer.p3d );

I'm ignoring something? Please Help
Hi Facu, could you send me a screenshot of the issue?
It would appear that you're missing the closing quotes when you load your character icons. You have:
LoadP3DFile( "art\frontend\dynaload\images\msnicons\char\barne.p3d );
LoadP3DFile( "art\frontend\dynaload\images\msnicons\char\homer.p3d );
In order for your code to work, you need:
LoadP3DFile( "art\frontend\dynaload\images\msnicons\char\barne.p3d" );
LoadP3DFile( "art\frontend\dynaload\images\msnicons\char\homer.p3d" );
yes, the mistake was the lack of closing quotes, thank you very much for the help of both!
Unsubscribe from this topic
Please login to contribute to the conversation.