Temporary solution to missing "mouse_cursor.p3d"

Posted in Support
Unsubscribe from this topic
Edit 2: The issue is resolved in 1.22.3: https://donutteam.com/forum/topic/2683

Edit: We've identified the of the issue and are actively looking into a fix. In the meantime, you can view the "Temporary Solutions" section for a list of fixes.

Original:

Hey everyone,

We've been getting reports of users immediately getting a message mentioning them missing "mouse_cursor.p3d" when running mods. While we've only gotten a handful of reports, we also know that some users will not immediately report this issue, so we wanted to reach out to everyone.

We're actively trying to gather information about what could be causing this issue. This thread will detail how you can help and a temporary solution.

I'm having this issue, how can I help?


Try using an older Mod Launcher:
Edit: We've confirmed older mod launchers do not work

Verifying Game Install
Edit: We've confirmed this is not relevant

Report Specs
Edit: We've confirmed specs are not relevant, however if you are having this issue, please let us know if you're running the game from a removable device such as a USB Stick or SD Card

Temporary Solution

There are two temporary solutions that will resolve this.

Move Game Install to an internal/external hard drive or solid state drive
We've identified an issue where the game does not load all of its necessary files when booting from an SD Card or USB Stick. You could move your game install to your hard drive/solid state drive temporarily while we develop a fix.

Command Line Argument
You're able to set a command line argument to use the legacy file system that has been thoroughly tested.

This is not an ideal solution and does cause some performance degradation, but will work in the meantime while we figure out what is going wrong.

1. Navigate to where you installed Lucas' Simpsons Hit & Run Mod Launcher to.
2. Create a file next to "Lucas' Simpsons Hit & Run Mod Launcher.exe" called "CommandLine.txt" (Image 1) - (Image 2)
3. Open the file in notepad and type "-legacyfilesystem" and save the file (Image)
UPDATE: I have managed to get mods to work on launchers 1.22 and 1.22.1. However I wanted to used DM4 public beta so If there is a solve to this that would be great. I will use temporary fix for now.

OS: Windows 10
RAM: 4GB
CPU: Intel Celeron (Integrated Graphics)
Are you able to remove -legacyfilesystem and instead put -debuglaunch

Once you press launch, a message similar to this will show up.

Once it shows up, press Control+C and paste it as a response to this thread please. Once done, press "Okay" and you can then remove "-debuglaunch"

If you don't want to submit that text publicly, you can make it into a text file and submit it here: https://www.dropbox.com/request/fVoy5u9huhrFyc4nYXVR
currently cant get the command line code to work. Are there any other settings I need to enable for it to work?
Does it look like this?


Once you have that in, press the "Launch" button in the Launcher and a window should show up. That's the window you'd press Control+C on and paste either into this thread or in that dropbox link

--

Also when running the old mod launchers, do you have a mod such as Road Rage Returns ticked?
yes I had DM3 ticked and it launched with no issues

And yeah it does look like that. I have a feeling it might be to do with the specs of my laptop or something it is a low end PC
And just to confirm, have you tried running DM3 on version 1.22.2 without -legacyfilesystem enabled and it failed?
yes. I tried with about two or three different mods. and it came up missing that file. I checked through to scripts of SHAR and the mouse cursor file was there.

give me a bit. I'll double check everything.
Thanks for your help, we're still trying to figure out what's going wrong exactly. This has only happened with two people so far.

When you double check, can you please make sure you don't have -legacyfilesystem enabled with the old launchers too. Also using -debuglaunch on the new mod launcher would be helpful.

If you have a Discord, this might be better to discuss in a chat like setting.
I'm on. Just need to get through the 10 minute authorisation.
Unsubscribe from this topic
This topic has been locked and can no longer be replied to.