This really is an application request, but here goes

Posted in Feature Requests
Unsubscribe from this topic
[deleted user]2 months
I recently got a really powerful Mac because my Thinkpad x230 is trash (which ran all of my SHAR Things such as the p3d editor and SHAR Mod Launcher). And wine doesn't comply with running SHAR Mod Launcher. Could there possibly be a port of the mod launcher and or P3D Editor like there is a mod launcher port for linux. I'm not requesting this as like "I NEED THIS NOW, THIS SHALL BE TOP PRIORITY", This is simply "If you feel like it, or can get around to it." And a suggestion would be making a Mod Launcher port, and having the Mod Launcher require a SHAR file and also Wine.

Thanks!
The nuances of using the mod launcher on Unix can get a bit complicated.

To give some background that isn't strictly required but is educational to know, the mod launcher can be abstracted to a C# frontend (UI) using the .NET Framework, that bootstraps C++ mods. Wine is able to handle the mods and the game itself (also C++) without any issue, but the .NET UI provides more challenge. On a Windows system, the .NET Framework redistributable can be installed to use it. On a Unix system though, there is no direct equivalent.

Given this, the options for using the mod launcher on Unix are just about:
- Using the Mono implementation of the .NET Framework. Mono has the ability to run natively on Linux and Mac OSX, and can also be integrated into Wine. This has not worked in my testing, but perhaps that may be something Lucas can look into.
- Using Microsoft's implementation of the .NET Framework. This does not have the ability to run natively on Linux and Mac OSX, and thus has to be translated in the same way that, say, the other C++ code is. In part thanks to Winetricks, this can be installed to a Wine prefix.
- Porting the UI to something that can natively run on Unix. I don't want to speak upon the mod launcher team's behalf, but this is likely something that would involve rewriting a lot of code.
- .NET 5.0 will merge the .NET Framework, Mono, and .NET Core (not yet mentioned in this post) into one. It will be some time until this becomes a realized, but for technical completeness I think it's worth mentioning.

As you might be able to deduct, my favored method is Microsoft's implementation. However, Wine (and by extension Winetricks) no longer works with the .NET 3.5 (the minimum version required by the launcher) installer, due to a regression (Winetricks issue #810 and #1291, among others.). Existing installations will continue to work, however it is not possible to install the prerequisite on the latest version of Wine at the moment. If you would still like to give it a shot, you can check out this post and try the Lutris installer or following the manual instructions (in which you would install Wine from here to account for the fact that you're using a Mac.).

In regards to a mod launcher "port" that uses Wine, I do have a tool that does exactly that, fulfilling a similar purpose to Lutris. However, it does not come with installers for all Linux distributions or Mac OSX, which I don't have a solution for at the moment.

Hopefully this explains everything, if you have any questions feel free to ask. If you're having issues with getting Wine to work on Mac OSX, consider joining the Discord server for more back-and-forth type discourse.
[deleted user]2 months
I knew this would be complicated, because if there is a linux launcher then there would indefinitely be a macOS equivalent. Hopefully this does get taken into consideration by the Mod Launcher team.
maybe you could use virtual box. (if its available for mac)
[deleted user]2 months
I've tried virtual box and failed many times because of it's horrible Direct3D Emulation. I tried Windows XP and Hit and Run but the game didn't work right because of the horrible beta of Direct3D in virtual box.
It should be noted that macOS Catalina, which is expected to be released this month, drops support for running 32-bit apps and this affects Wine.

If you update to this version of macOS, it will be impossible to do this for the foreseeable future.
Unsubscribe from this topic
Please login to contribute to the conversation.